[CentOS] skypeforlinux lacks dependencies, won't update

Thu Nov 23 06:49:55 UTC 2017
Sorin Srbu <Sorin.Srbu at orgfarm.uu.se>

> -----Original Message-----
> From: CentOS [mailto:centos-bounces at centos.org] On Behalf Of ken
> Sent: den 22 november 2017 20:14
> To: centos at centos.org
> Subject: Re: [CentOS] skypeforlinux lacks dependencies, won't update
> On 11/19/2017 12:53 PM, vychytraly . wrote:
> > Maybe try flatpak version? there should be no problems with
> dependencies
> > there... :)
> Thanks, I didn't know about flatpak... even tho it's in the base repo!
> I have to admit though, after reading through the flatpak website about
> it, I still don't understand how it could overcome the dependency
> problem with the skypeforlinux update.  Grateful for enlightenment.
> >
> > On Sat, Nov 18, 2017 at 7:02 PM, ken <gebser at mousecar.com> wrote:
> >
> >> For about a week now yum has tried and failed to update skypeforlinux:
> >>
> >> Packages skipped because of dependency problems:
> >>      skypeforlinux- from skype-stable
> >>
> >> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.20)(64bit) for
> package:
> >> skypeforlinux-
> >>
> >> Is there any resolution to this issue?

Please excuse the sidetrack.

I had to do a Skype-meeting yesterday evening. Some weirdness occurred.

A background; Have two OEM:s, one at work, one at home. Same hardware, same 
OS - CentOS 7.4 x64, same repos and both fully updated, same software 
installed. I believe the chassis differ though(...).

At work, the rpm from https://www.skype.com/en/get-skype/, refused to install 
with the same errors as above regarding the libs.

The Skype Flatpak from 
https://flathub.org/repo/appstream/com.skype.Client.flatpakref installed just 
fine and the test call showed no problems, so that's what I installed at home 

The Skype flatpak at home worked beautifully, that is to say for about ten 
minutes, then the sound (using a Koss SB/45 headset) it started crackling to 
the point of not being usable anymore. I hung up and reconnected, then sound 
was fine, for another ten minutes at which point the crackling returned.
Checking the sound prefs, I saw that alsa on the app tab had two instances, 
one stable and one that blinked like crazy, like it was opening and closing a 
few times a second.

On a hunch I downloaded the skype for linux rpm from the link above and 
installed it with yum.
No lib errors!
I started it and gave it a go, and - no crackling whatsoever. In fact it 
worked as good as it gets IMHO.

Is there anything that could account for the problem I had?
I read that the network bandwidth may be a problem, and that five Mbps at a 
minimum with video is the low mark.
At work I sit on a 1 Gbps up/down network. At home I have 100 Mbps up/down. I 
have doubts that the network width was the problem.

Are flatpaks known to cause odd problems at all?