[CentOS] Issues booting centos7 [dracut is failing to enable centos/root, centos/swap LVs]

Tue Jul 31 20:47:21 UTC 2018
mark <m.roth at 5-cent.us>

Yannis Milios wrote:
> Finally, I was able to find a solution for this. I'm posting the result
> here, just in case that it's useful for someone else in the future ...
> The problem was not in initramfs (dracut), but on the fact that /dev/sda2
>  partition(PV),  after I resized it, somehow got 2  partition table
> signatures.
> One was set as a "dos" partition with an offset "0x1fe" and second set as
>  "LVM_member" with an offset "0x8e".
> This confused blkid in initramfs, during the initial boot stage, thinking
>  that /dev/sda2 is *not* an LVM_member but rather a simple "dos"
> partition, hence refused to activate centos/root and centos/swap LVs which
> were required to boot the machine to the O/S.
Glad you solved it. Btw, in the future, if you have a problem that you
finally get resolved, after much difficulty, and go to post the solution,
add [SOLVED] to the subject line. Gets people's attention.