[CentOS] CentOS 7 system unsable after "yum update" (with some errors on the way)

Fri May 25 13:57:31 UTC 2018
Toralf Lund <Toralf.Lund at pgs.com>

God dag,

I've been trying to run a "yum update" (without additional arguments) to install the latest system updates on my CentOS 7 machine. It's no going so well. What happens is this:

  1.  The process gets stuck a couple of places as a "post" script or similar tries to run "dbus-send"; the problem looks awfully similar to what's described in https://bugzilla.redhat.com/show_bug.cgi?id=1186018. More specifically, this happens on installation of package "setroubleshoot" and "avahi". As a workaround, I'm using a manual kill to get rid of the hung process.
  2.  There is a similar hang related to "systemctl try-restart". This happens on "wpa_supplicant" clean-up.
  3.  When I restart the system after the installation is done (with work-arounds), it won't boot properly - I don't get a login screen or console login prompt. I notice two error messages on the boot console:
Failed to start login service
Failed to start WPA supplicant daemon

I've tried the operation twice with the same result. First time was just after the release of CentOS 7.5, I believe. I've done similar upgrades before that, too, and they've completed without problems.

Has anyone else seen this? Any ideas what I can do to make the system usable again, besides restoring from back-up (as I'm doing now)?

There is info on the net that suggests that the problem is related to SELinux and that a relabel operation and/or policy change would help, but I tried all sorts of things related to that the first time around, and nothing seemed to help. (I was working partly in rescue mode booted from an installer USB and partly in single user mode, which does work.)


- Toralf