[CentOS] GNOME, numeric keypad & commas

Sun Sep 2 18:03:10 UTC 2018
Gregory P. Ennis <PoMec at PoMec.Net>


Our local school has a 100 % CentOS network on servers and desktops.
Until recently, we were using a highly customized Xfce desktop
environment. Last week I decided to migrate all desktops from Xfce to
GNOME, which went quite well. Now I have to sand down some rough edges.

The secretary complained that she can't use the numeric keypad as
before. She's using LibreOffice Calc a lot, and she has to type in a
of numbers with commas. With Xfce this was not a problem. Under GNOME,
this won't work anymore. As far as I can tell, this has to do with the
locale-specific syntax of 0.00 vs 0,00. Our systems are all localized

Any idea how this can be solved?





Thank you for your post.  I have just created a hypervisor with kvm and
centos 7.5, and posted the same keypad problem I thought was related to
kvm, but when I checked on my host centos 7.5 machine as opposed to the
guest machines, the keypad did not work on it either.  Looks like there
is a problem with the latest version of gnome3 in Centos 7.5.

Greg Ennis



After doing some additional testing, I was certainly not able to use
the numeric keypad on either the host machine or the guest machines
when each was using gnome3 as the desktop.  However, when I used kde as
the desktop on the host machine the numeric keypad worked perfectly not
only on the host machine, but also on the guest machine even when the
guest machine was using gnome3 as the the desktop.

It looks to me like there is a problem with gnome3 when it is used on a
host machine; the numberic keypad is disabled.

I will be watching this thread with the hopes that someone will have an
answer, but for now at least I can use kde on the host, and gnome3 on
the guest and have my numeric keypad work.

Greg Ennis