[CentOS] midco stealling searches, was browsers slowing Centos 7 installation to a crawl

Wed Dec 4 15:39:55 UTC 2019
Louis Lagendijk <louis at fazant.net>

On Tue, 2019-12-03 at 16:33 -0600, Michael Hennebry wrote:
> For whatever reason,
> the problem I was trying to solve seems to have gone away.
> I can type in firefox's search box without midco stealing searches.
> Something changed resolv.conf behind my back.
> search midcoip.net
> is there again.
> I hadn't rebooted or changed firefox's preferences.
> I'm guessing it was when I turned the connection off and on.
> To be sure my joy was not tempory, I rebooted.
> midco still not stealing searches.
> I wish I knew what the problem had been and what fixed it.
The search parameter in resolv.conf is not related in any way to the
searches in the browser. It just defines the domain to be added to
hostnames that you want to resolve. So if you do a name lookup for foo,
the resolver would add  midcoip.net so you get the ip-address for
foo.midcoip.net if foo on its own could not be resolved.

It midcoip wanted to steal your browser searches, it would have to
hijack google.com, but that would not work as the browser would not
connect as the https certificate wold be invalid.
So you need to look at the browser settings to see what is happening
there. DNS is most likely not involved.