[CentOS] printer only prints one page, if anything

Fred Smith

fredex at fcshome.stoneham.ma.us
Thu Nov 7 04:00:42 UTC 2019

On Wed, Nov 06, 2019 at 05:16:52PM -0600, Michael Hennebry wrote:
> On Wed, 6 Nov 2019, Fred Smith wrote:
> >It looks as if you downloaded the two RPMs from Brother then attempted
> >to follow their complicated instructions for installing them. Much
> >simpler is to do this:
> >
> >linux-brprinter-installer-2.1.1-1 is the brother printer driver
> >installer I used on my HL-L2360D.
> I had tried that also, but tried it again.
> before my last try, I power-cycled the printer.
> This time it worked.
> For some reason CUPS now shows two queue names:
> HL-L2360D-series   Brother HL-L2360D series   localhost.localdomain
> HL-L2360D          HLL2360D
> both Brother HL-L2360D for CUPS    .
> 'Tain't as big a deal as having none,
> but why does CUPS have two queue names for the printer?

'Fraid I have no clue. sorry.

we have two brother printers here, and when I look at "manage printers" in
the CUPS web page I see this:

Queue Name 	Description	Location	Make and Model			Status
DCP7065DN	DCP7065DN			Brother DCP7065DN for CUPS	Idle
HLL2360D	HLL2360D			Brother HL-L2360D for CUPS 	Idle

one per printer. Is it possible that one of yours is cruft left over from
previous attempts? You said it works now,... does that mean you can choose
either of the two it shows and get printouts?

> >it asks a few questions, some more cryptic than others, and then
> >downloads and installes the required packages, after which I ran the
> >system-config-printer tool and set up my printer. Voila!
> I think they were the same packages that I tried to use.
> In any case, they both ended in 386.
> Had not heard of system-config-printer .
> Neither man, info nor --help helped.
> What is it suppoded to do?

I'm using the MATE desktop, so it may be that Gnome 3.x no longer has it, or
has renamed it. Can't help you there.

But it is a gui you use to configure printers.

> Google suggests it is a GUI.
> Google also suggests that it is always started through a GUI.
> Is it under Sundry, Print Settings?

yum whatprovides */system-config-printer replies:

	system-config-printer-1.4.1-21.el7.x86_64 : A printer administration tool
	Repo        : base
	Matched from:
	Filename    : /usr/bin/system-config-printer

	system-config-printer-libs-1.4.1-21.el7.noarch : Libraries and shared code for printer administration tool
	Repo        : base
	Matched from:
	Filename    : /usr/share/system-config-printer

> >As I also said previously in this thread, I set up the same printer
> >on Centos-8 without installing any Brother drivers, by going direct
> >to CUPS on port 631 and selecting Brother 2460 (since it didn't offer
> >2360). Here are two entries from /etc/cups/printers.conf:
> My printer worked in July.
> At the time, it did not have Brother drivers.
> I don't know what update broke it or how.
> Is there an easy way to rename or alias a queue?

Again, I can't help you with this. sorry.

There is a ton of CUPS documentation, though, you may be able to find
an answer there.


    Under no circumstances will I ever purchase anything offered to me as
    the result of an unsolicited e-mail message. Nor will I forward chain
    letters, petitions, mass mailings, or virus warnings to large numbers
    of others. This is my contribution to the survival of the online
 --Roger Ebert, December, 1996
----------------------------- The Boulder Pledge -----------------------------

More information about the CentOS mailing list