[CentOS] printer only prints one page, if anything

Michael Hennebry

hennebry at web.cs.ndsu.nodak.edu
Thu Nov 7 19:10:00 UTC 2019

On Thu, 7 Nov 2019, Pete Biggs wrote:

[Michael Hennebry]
>> 'Tain't as big a deal as having none,
>> but why does CUPS have two queue names for the printer?
> Do you have CUPS autodiscover turned on?  (AKA Avahi on Linux systems),
> if so CUPS will have automatically added the printer in addition to the
> one you manually added.

Ah.  That makes sense.

>> I think they were the same packages that I tried to use.
>> In any case, they both ended in 386.
> Once again, do you have a 64 bit system?  If so, then any executables
> in the RPMs won't work unless you have added the 32-bit compatibility
> stuff.  RPMs aren't magic, they need to have the requirements added by
> the packager and if the requirements aren't mentioned in the RPM, it
> will still install, but none of the executables will run.  They will
> come up with Bad ELF errors.

It must have found whatever it needed:
Both queues work.

> system-config-printer is the old way of adding and managing printers.
> It's a GUI, but you can start it from a command line in a GUI
> environment (i.e. it's not a command line program).  But it's just a
> front end, you still need the underlying drivers there before it can
> configure a printer.

Add printer worked after I added myself to the lp and sys groups.
The cups_error file gave me something to search for.

All good now.

Michael   hennebry at web.cs.ndsu.NoDak.edu
"Sorry but your password must contain an uppercase letter, a number,
a haiku, a gang sign, a heiroglyph, and the blood of a virgin."
                                                              --  someeecards

More information about the CentOS mailing list