[CentOS] printer only prints one page, if anything

Pete Biggs

pete at biggs.org.uk
Thu Nov 7 09:46:45 UTC 2019

> I had tried that also, but tried it again.
> before my last try, I power-cycled the printer.
> This time it worked.
> For some reason CUPS now shows two queue names:
> HL-L2360D-series   Brother HL-L2360D series   localhost.localdomain
> HL-L2360D          HLL2360D
> both Brother HL-L2360D for CUPS    .
> 'Tain't as big a deal as having none,
> but why does CUPS have two queue names for the printer?

Do you have CUPS autodiscover turned on?  (AKA Avahi on Linux systems),
if so CUPS will have automatically added the printer in addition to the
one you manually added.

> I think they were the same packages that I tried to use.
> In any case, they both ended in 386.

Once again, do you have a 64 bit system?  If so, then any executables
in the RPMs won't work unless you have added the 32-bit compatibility
stuff.  RPMs aren't magic, they need to have the requirements added by
the packager and if the requirements aren't mentioned in the RPM, it
will still install, but none of the executables will run.  They will
come up with Bad ELF errors.

> Had not heard of system-config-printer .
> Neither man, info nor --help helped.
> What is it suppoded to do?
> Google suggests it is a GUI.
> Google also suggests that it is always started through a GUI.

The god Google is not infallible.

system-config-printer is the old way of adding and managing printers.
It's a GUI, but you can start it from a command line in a GUI
environment (i.e. it's not a command line program).  But it's just a
front end, you still need the underlying drivers there before it can
configure a printer.

However, system-config-printer is deprecated in CentOS 7 and I believe
it's not in CentOS 8 (I could be wrong though).  The official way to
manage printers in CentOS 8 is either via CUPS or cockpit.


More information about the CentOS mailing list