[CentOS] qeum on centos 8 with nvme disk

Sun Oct 13 18:56:59 UTC 2019
Jerry Geis <jerry.geis at gmail.com>

>6 hours are too much. First of all you need to check your nvme
>performace (dd can help? dd if=/dev/zero of=/test bs=1M count=10000 andd
>see results. If you want results more benchmark oriented you could try
>bonnie++ as suggested by Jerry).

>Other this, have you got kvm module loaded and enabled cpu
>virtualization option in the BIOS?

>If yes, have you got created the VM using --accelerate?

>Have you tried another distro on VM?

I mounted the partition under C7.7 and ran the nvme test. Pretty much
came back in seconds for 10G test.

 dd if=/dev/zero of=test bs=1M count=10000
10000+0 records in
10000+0 records out
10485760000 bytes (10 GB) copied, 5.45451 s, 1.9 GB/s

Yes kvm_intel is loaded as a module.

I am using the "-hda /dev/nvme0n1" when I run qemu.... I'm thinking this
works find for my other "img" files - but does not work for "well" for my
physical NVME.
What is the correct argument perhaps to use for running a physical NVME
disk as a qemu guest ??