[CentOS] Diagnosing IPv6 routing

Tue Apr 28 20:57:34 UTC 2020
Alan McRae <amcrae at island42.net>

I struggled with this under CentOS 7. I think there is a bug.

You can run /usr/sbin/radvdump to print out RAs. Leave it running for 
some minutes.

I had this in my /etc/sysctl.d/50-net6.conf (on C7):

# IPv6 Forwarding
net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.default.forwarding = 1
net.ipv6.conf.all.accept_ra = 1
net.ipv6.conf.default.accept_ra = 1
# Fix bug to received RAs from Router
# Disable forwarding on enp4s0f1 interface so we still get RAs
net.ipv6.conf.enp4s0f1.forwarding = 0
#net.ipv6.conf.enp4s0f1.accept_ra = 1

where enp4s0f1 is the WAN interface. Note that ipv6 forwarding still 
works. I used my C7 as a firewall/gateway.

I am running 8.1 now.


Alan McRae

On 29/04/2020 06:54, Kenneth Porter wrote:
> I just got 50 Mbps symmetric fiber from AT&T and it includes a /56 of 
> IPv6 addresses, replacing a much slower ADSL line. I never tried to 
> get IPv6 working on the old connection. I'm using CentOS 7 as a 
> gateway and it's worked great for several versions for IPv4.
> I'm not seeing any IPv6 default route on the WAN interface. I suspect 
> I'm not getting route announcements. I think I have all the IPv6 
> variables in ifcfg-em2 set right. But I do notice that the accept_ra 
> file in proc for that interface has value 1, not 2. Changing it to 2 
> doesn't change anything, though. No route appears.
> While I wait for an answer to my trouble ticket, is there some way to 
> verify that I'm not receiving any RA packets? Is there a way to force 
> a solicitation for one? Is there a tcpdump invocation I can use to 
> watch for them? Are there log messages that will tell me when an RA 
> has been seen and added to the routing table or ignored?
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos