[CentOS] Diagnosing IPv6 routing

Tue Apr 28 18:54:23 UTC 2020
Kenneth Porter <shiva at sewingwitch.com>

I just got 50 Mbps symmetric fiber from AT&T and it includes a /56 of IPv6 
addresses, replacing a much slower ADSL line. I never tried to get IPv6 
working on the old connection. I'm using CentOS 7 as a gateway and it's 
worked great for several versions for IPv4.

I'm not seeing any IPv6 default route on the WAN interface. I suspect I'm 
not getting route announcements. I think I have all the IPv6 variables in 
ifcfg-em2 set right. But I do notice that the accept_ra file in proc for 
that interface has value 1, not 2. Changing it to 2 doesn't change 
anything, though. No route appears.

While I wait for an answer to my trouble ticket, is there some way to 
verify that I'm not receiving any RA packets? Is there a way to force a 
solicitation for one? Is there a tcpdump invocation I can use to watch for 
them? Are there log messages that will tell me when an RA has been seen and 
added to the routing table or ignored?