[CentOS] Centos 7 shim fix failed

Tue Aug 4 17:54:50 UTC 2020
david <david at daku.org>

Following the advice on this mailing list, I rebuilt (from scratch) 
Centos 7.8.  I added the following line into /etc/yum.conf before the 
first update:

exclude=grub2* shim* mokutil

The system worked fine.  I was able to do general updates
   yum -y update
and all was well.

HOWEVER, following Johnny Hughes' directions:

a) remove the 'exclude' line from yum.conf
b) perform update:  yum -y update
c) reinstall kernel.  Here the instructions were vague, so I typed in...
   yum reinstall kernel-3.10.0
deriving the "3.10.0" label by the output of
   rpm -qa | grep kernel

Yum got up to the point:

Running transaction
   Installing : 

at which point the process appeared to hang.  No further output 
happened for five minutes.  I opened a different terminal and entered 
"shutdown -r now".  The result is an unbootable system.

What did I do wrong?  I must admit that there are multiple copies of 
advice on the mailing list, so perhaps I followed the wrong one?


So now, I tried the 'repair' mechanism, but couldn't make that work 
either.  So, it was back to initial from-scratch install.