[CentOS] Fixing grub/shim issue Centos 7

Fri Aug 7 09:44:03 UTC 2020
Alessandro Baggi <alessandro.baggi at gmail.com>

Il 07/08/20 10:47, Johnny Hughes ha scritto:
> On 8/7/20 2:40 AM, Alessandro Baggi wrote:
>> Il 07/08/20 08:22, Johnny Hughes ha scritto:
>>>> "How on earth could this have passed Q & A ?"
>> Hi Johnny,
>> Niki's question is spread, legit, in the thoughts in many and many users
>> so don't see this as an attack. Many and many users,though really "if
>> this was tested before release" and I think that many of us are
>> incredulous at what happened on CentOS and in the upstream (specially in
>> the upstream) but as you said CentOS inherits RHEL bugs. I'm reading
>> about many users that lost their trust in RH with the last 2 problem
>> (microcode and shim). This is bad for CentOS.
>>> Well, I mean that would be a valid point if it happened for every
>>> install.  The issue did not happen on every install.  There is no way to
>>> test every single hardware and firmware combination for every single
>>> computer ever built :)
>>> It would be great if things like this did not happen, but with the
>>> universe of possible combinations, i am surprised it does not happen
>>> more often.
>> Probably many users have not updated their machines between the bug
>> release and the resolution (thanks to your fast apply in the weekend,
>> thank you) and many update their centos machines on a 2 months base (if
>> not worst). I think also that many users of CentOS user base have not
>> proclamed their disappointement/the issue on this list or in other
>> channels. For example I simply updated in the wrong time.
>>> We do run boot tests of every single kernel for CentOS.  The RHEL team
>>> runs many more tests for RHEL.  But every possible combination from
>>> every vendor can't possibly be tested. Right?
>> you are right but is not UEFI a standard and it shouldn't work the same
>> on several vendors? I ask this because this patch broken all my uefi
>> workstations.
> It would be nice if it did .. however, this worked on many
> UEFI/Secureboot machines.  It did not work on a small subset of machines.
>> While CentOS team could not have so much resources to run this type of
>> tests would be great to know what happened to RHEL QA (being RH giant)
>> for this release and given the partenership between CentOS and RH if you
>> know something more on this.....
> I have not seen the full post event account if what actually happened.
> I do know that many Red Hatters worked many hours over the last weekend
> to fix it.  I am sure a public post will be made (if not already there)
> .. if someone knows where it is, post a link.
> If I don't see it posted soon, I'll look for it and post here.
Thank you Johnny.