[CentOS] Installing devtoolset-6 on CentOS 8

Tue Aug 18 09:51:17 UTC 2020
Pete Biggs <pete at biggs.org.uk>

On Mon, 2020-08-17 at 19:28 -0400, Eric Gervais-Despres wrote:
> Has anybody tried (and succeeded) to get gcc 6.3.1 (or devtoolset-6) to
> work on CentOS 8?

As far as I can see SCL & devtoolset are not available for CentOS 8 -
the toolsets are integrated as part of the main distro, and they are
only for newer versions of GCC and not older ones.

> In the Animation and Visual Effect industry, gcc 6.3.1 is still the current
> recommended compiler (see www.vfxplatform.com), and is required to build
> many plugins. Unfortunately, it is not a "minimum requirement"... It is THE
> requirement.
> So I tried to get it from the vault:
> -- 
> sudo dnf config-manager --add-repo=
> http://vault.centos.org/7.6.1810/sclo/x86_64/rh/
> sudo dnf install devtoolset-6
> --
> but I get these messages:
> --
> Error:
> Problem: package devtoolset-6-6.1-1.el7.x86_64 requires
> devtoolset-6-runtime, but none of the providers can be installed
> conflicting requests
> nothing provides policycoreutils-python needed by
> devtoolset-6-runtime-6.1-1.el7.x86_64
> (try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
> use not only best candidate packages

Yes, you are trying to install a CentOS7 package on CentOS8.  It
probably won't work.

> I hate having to install something not officially supported anymore, but
> still officially required for many current software.

It depends what it is about GCC v6 you need - you can control the
dialect of C that GCC act as using the '-std='.  Ultimately though,
just download that particular version of GCC and compile/install it,
it's not a difficult thing to do and most of it is automated.

Strangely though, GNU doesn't seem to think that 6.3.1 exists, the
nearest on the GCC downloads is 6.3.0.