[CentOS] Installing devtoolset-6 on CentOS 8

Mon Aug 17 23:28:24 UTC 2020
Eric Gervais-Despres <ericgd at ngeniousstudio.com>

Has anybody tried (and succeeded) to get gcc 6.3.1 (or devtoolset-6) to
work on CentOS 8?

In the Animation and Visual Effect industry, gcc 6.3.1 is still the current
recommended compiler (see www.vfxplatform.com), and is required to build
many plugins. Unfortunately, it is not a "minimum requirement"... It is THE

So I tried to get it from the vault:
sudo dnf config-manager --add-repo=
sudo dnf install devtoolset-6
but I get these messages:
Problem: package devtoolset-6-6.1-1.el7.x86_64 requires
devtoolset-6-runtime, but none of the providers can be installed

conflicting requests
nothing provides policycoreutils-python needed by
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to
use not only best candidate packages
All options fail.

I hate having to install something not officially supported anymore, but
still officially required for many current software.

Thank you.

*Éric Gervais-Després*
4270 St-Laurent #300
Montréal, Qc, Canada, H2W 1Z3
*www.ngeniousstudio.com <http://www.ngeniousstudio.com>*