[CentOS] 8-stream dnf overly verbose

Fri Dec 11 14:27:29 UTC 2020
Marek Blaha <mblaha at redhat.com>

On Thu, Dec 10, 2020 at 6:54 PM Pete Biggs <pete at biggs.org.uk> wrote:
> In moving a test machine from 8.3 to 8-stream the main thing I've
> noticed is that dnf has become very verbose. It's as if someone has
> turned on the -v permanently.
> I've tried using '-q' (it says nothing then) and I've tried adjusting
> the debuglevel, but nothing seems to affect it.  I get things like
> this:
> Downloading: http://mirrorlist.centos.org/?release=8-stream&arch=x86_64&repo=BaseOS&infra=stock
> Downloading: http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repodata/repomd.xml|   0  B     --:-- ETA
> Downloading: http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repodata/c2f9210df3e5c24d45228e360eb1f405367c1286d36ec91bf930abb944e3ac44-primary.xml.gz
> Downloading: http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repodata/b412debc52ee7c094b8de2c57a0d6d8827828154a6cd0e1995d588273028a4fe-filelists.xml.gz
> Downloading: http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repodata/6cd252c469b0dd0c67bc8d8b4ab2df44fb24de52c93decdfe7acc77b97361490-comps-BaseOS.x86_64.xml.xz
> CentOS Stream 8 - BaseOS                                                                 13 MB/s | 2.3 M
> For every repo when there's nothing cached. It never used to do this.
> How can I turn off the "Downloading:" messages?
> P.

The problem is that the version of dnf in CentOS stream does not match
the version of libdnf used.
I've filed a bug: https://bugzilla.redhat.com/show_bug.cgi?id=1906839
on CentOS Stream distribution.