[CentOS] 8-stream dnf overly verbose

Fri Dec 11 15:53:04 UTC 2020
Randal, Phil <phil.randal at hoopleltd.co.uk>

Funnily enough mere mortals like me aren't allowed to view that bug report.

RedHat might have to rethink a few things.



-----Original Message-----
From: CentOS <centos-bounces at centos.org> On Behalf Of Marek Blaha
Sent: 11 December 2020 14:27
To: CentOS mailing list <centos at centos.org>
Subject: Re: [CentOS] 8-stream dnf overly verbose

This message originated from outside of Herefordshire Council or Hoople. Please do not click links or open attachments unless you recognise the sender and know the content is safe.

On Thu, Dec 10, 2020 at 6:54 PM Pete Biggs <pete at biggs.org.uk> wrote:
> In moving a test machine from 8.3 to 8-stream the main thing I've
> noticed is that dnf has become very verbose. It's as if someone has
> turned on the -v permanently.
> I've tried using '-q' (it says nothing then) and I've tried adjusting
> the debuglevel, but nothing seems to affect it.  I get things like
> this:
> Downloading: http://mirrorlist.centos.org/?release=8-stream&arch=x86_64&repo=BaseOS&infra=stock
> Downloading: http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repodata/repomd.xml|   0  B     --:-- ETA
> Downloading:
> http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repod
> ata/c2f9210df3e5c24d45228e360eb1f405367c1286d36ec91bf930abb944e3ac44-p
> rimary.xml.gz
> Downloading:
> http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repod
> ata/b412debc52ee7c094b8de2c57a0d6d8827828154a6cd0e1995d588273028a4fe-f
> ilelists.xml.gz
> Downloading: http://mirror.cov.ukservers.com/centos/8-stream/BaseOS/x86_64/os/repodata/6cd252c469b0dd0c67bc8d8b4ab2df44fb24de52c93decdfe7acc77b97361490-comps-BaseOS.x86_64.xml.xz
> CentOS Stream 8 - BaseOS                                                                 13 MB/s | 2.3 M
> For every repo when there's nothing cached. It never used to do this.
> How can I turn off the "Downloading:" messages?
> P.

The problem is that the version of dnf in CentOS stream does not match the version of libdnf used.
I've filed a bug: https://bugzilla.redhat.com/show_bug.cgi?id=1906839
on CentOS Stream distribution.


CentOS mailing list
CentOS at centos.org
Hoople Ltd, Registered in England and Wales No. 7556595
Registered office: Plough Lane, Hereford, HR4 0LE

"Any opinion expressed in this e-mail or any attached files are those of the individual and not necessarily those of Hoople Ltd. You should be aware that Hoople Ltd. monitors its email service. This e-mail and any attached files are confidential and intended solely for the use of the addressee. This communication may contain material protected by law from being passed on. If you are not the intended recipient and have received this e-mail in error, you are advised that any use, dissemination, forwarding, printing or copying of this e-mail is strictly prohibited. If you have received this e-mail in error please contact the sender immediately and destroy all copies of it."