[CentOS] UEFI boot blank screen post update

Fri Jul 31 02:52:47 UTC 2020
Greg Bailey <gbailey at lxpro.com>

On 7/30/20 7:43 PM, Anshu Prateek wrote:
> Hi folks,
> I am able to install workstation successfully on a dedicated SSD w/ GPT
> partition w/ UEFI boot using the latest `CentOS-8.2.2004-x86_64-dvd1.iso`
> from a bootable pen drive.
> The motherboard is ASRock x570 Gaming 4 (
> https://www.asrock.com/mb/AMD/X570%20phantom%20Gaming%204/index.asp) w/
> Ryzen 3600, 16G RAM, 1TB SSD in question.
> However, after login, when I do a DNF update (which is updating the kernel
> presently) and then do a reboot, I don't see the grub2 screen anymore. I
> end up on a blank screen. Tried fixing grub2 via recovery method, no luck.
> Tried this couple of times, i.e, fresh install then dnf update, always
> ended up with the same result.
> In my latest reinstall, I did not format the boot and EFI partition, and
> after it came up post the reinstall, I could see the upgraded kernel entry
> from the last install in the grub menu.
> Thoughts on what could be causing this and how could I fix it?

I'm running CentOS 8.2 on an Intel NUC, and also hit this this morning.  
The way I was able to workaround this was to copy grub2-* and shim-* 
RPMs from the CentOS 8.2 installation media and use "rpm -Uvh grub2-* 
shim-* --oldpackage".  The subsequent reboot worked normally.  The 
versions of those packages on the 8.2 installation media was the same as 
what I had installed immediately before this morning's upgrade.