[CentOS] Zoom....

Sat May 9 20:58:15 UTC 2020
mark <m.roth at 5-cent.us>

On 2020-05-09 16:20, Barry Brimer wrote:
>>   Updated CentOS 7 the other day. Updated zoom last night. Ancient (15 
>> yr old) USB camera, Logitech QuickCam Express. (There are zero available newer, that I could get before June.)
>>   If I run LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so cheese, I get 
>> video. Zoom, with or without the LD_PRELOAD - no video. I've tried 
>> stracing zoom, and created a file /etc/ld.so.preload, with the 
>> contents of /usr/lib64/libv4l/v4l2convert.so, and in strace, I see it 
>> loading it, but still no video.
> I assume you're using the Zoom Linux client since you updated Zoom. 
> Thinking out loud .. I wonder what would happen if you:

> Booted a CentOS 7.6 kernel keeping all else the same

It didn't work with 6.x. I rebuilt the beginning of April to CentOS 7. 
Didn't work, until I got rid of the default gspca_spca561, and used the 
gspca_spca508. Updated the beginning of this week, and didn't work until 
I went back to gspca_spca561.

Works 100% of the time with cheese, when I add that preload.
> Booted from a variety of CentOS / Fedora Live CD images to see what 
> kernels do / don't work if it's even kernel related
> Try using Zoom via Chrome which can do pretty much everything natively 
> without Zoom extension

I was really, really trying to avoid installing chrome.
> Try using Zoom via Chrome with Zoom extension
> Try using Zoom via Firefox with Zoom extension (Zoom with Firefox 
> without Zoom extension is very limited)

Been trying to join a test meeting in firefox, and it opens a new tab, 
and demands that I use the app.
> Hope this helps.
Thanks for trying.... I may have to try chrome (really didn't want 
google scanning what I do to sell it.