[CentOS] CentOS 7 - xfs shrink & expand

Wed May 13 12:20:47 UTC 2020
Frank M. Ramaekers Jr. <frank at ramaekers.com>

Yeah, I tried that but ran into a problem.  It came up fine in 
single-user/maintenance mode.   The mount command shows all of the 
mounted file systems, but after I 'chroot /sysroot', the mount failed 
(with some problem with mtab, sorry don't have the exact error 
message).  So I couldn't mount my 32TB RAID (where the xfsdump file was).

On 5/13/2020 12:48 AM, Simon Matter via CentOS wrote:
> Hi,
>> I'm having some difficulty finding a method to shrink my /home to expand
>> my /.  They both correspond to LVMs.  It is my understanding that one
>> cannot shrink a xfs filesystem.  One must back it up (xfsdump), remove
>> (lvremove) redefine it and then restore it back (xfsrestore).
>> Okay, I'm running into a problem where /home  needs to be "unused".  If
>> tried going in to "maintance mode", but I ran into a problem with the
>> mount command (after issuing a 'chroot /sysroot').  I then tried using
>> SystemRescueCD to boot to, but it wouldn't mount my 32TB RAID USB drive
>> (something about too big).
>> Any thoughts or suggestions?
> What is the problem if you boot directly into maintenance mode? Then it
> should be possible to backup home to a remote destination, unmount /home,
> remove the home LV, expand /, recreate home and mount it, restore from
> backup and you're done. No need to use any SystemRescueCD or other tool.
> Regards,
> Simon
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos