[CentOS] mkfs.fat Device or resource busy

Mon May 25 01:30:00 UTC 2020
Michael Hennebry <hennebry at web.cs.ndsu.nodak.edu>

On Sun, 24 May 2020, Robert Heller wrote:

> At Sun, 24 May 2020 18:33:25 -0500 (CDT) CentOS mailing list <centos at centos.org> wrote:
>> I'm trying to format a 16 GB SD card to FAT32.
>> Either it won't find the device or it
>> gives me the titular error message.
>> mkfs.fat /dev/sdc
> First of all, doing it *without* a partition table is not going to work (well
> mkfs.fat is not going to care (once you deal with the other error).  Since

Thanks much!
That was it.
It did care.
At one point I was even told something like,
won't do it, partition table.

> you are formatting iy FAT32, I'm presuming you will be using it in some device
> (eg camera, mess-windows machine, etc.).  You want an MBR partition table --

Actually, I'm trying to update my BIOS.
The instructions I found require FAT32.

>> I have tried "ejecting" the drive and reinserting the card.
>> I have tried inserting another card, checking to insure
>> that I could see its file, ejecting that card and
>> inserting the target card.
>> If I do not umount it, busy, if I don't, not found.
> I'm guessing you are using a GUI and the GUI has some "magic" GUI mounter hack
> that automagically mounts USB disks when they show up. You probably have to
> turn that off or work around it. I guess umount from a shell will work. Eject

I used eject from the GUI and umount from the command line.

> won't work, since that not only umounts the file system, it also removes the
> device files (hense "device not found").

Michael   hennebry at web.cs.ndsu.NoDak.edu
"Sorry but your password must contain an uppercase letter, a number,
a haiku, a gang sign, a heiroglyph, and the blood of a virgin."
                                                              --  someeecards