[CentOS] System not logging

Thu Oct 29 08:06:10 UTC 2020
Roberto Nunnari <robi at nunnari.ch>


Check if you still have rsyslog installed on that box.
On one of my new CentOS 8 servers, rsyslog somehow disappeared (or never 
was installed).
I had to install it manually.

Best regards.

Il 2020-10-28 16:09 Gary Stainburn ha scritto:
> One of my boxes has stopped logging some of the things it's supposed
> to.  I use rsyslog which used to send named and dhcpd entries to
> separate log files.  Both named and dhcpd are working. I have shut
> down the DHCPD server and run it in debug mode and the output is
> produced as expected.
> I have shut down rsyslog and run that in debug mode and it looks like
> everything is running, but it's not receiving messages to log.
> I tried
> journalctl | grep -Ei 'dhcpd'|tail
> and I see the log entries for the service starting up, but no entries
> for DHCP transactoins happening.
> My rsyslog also receives network messages from my firewall and they
> are logging as expected.  This suggests to me that the problem is that
> the log entries are either not being generated, or are not being
> allowed to get to rsyslog.
> Anyone go any ideas?
> I've tried the usual first step, and briefly disabled selinux but that
> made no difference
> Gary
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos