[CentOS] rpm spec:: Requires conditions format :: lower not working

Tue Sep 8 14:53:03 UTC 2020
Adrian Sevcenco <Adrian.Sevcenco at spacescience.ro>

Hi! I'm trying to give a range of versions for a dependency in the form of :
Requires: xrootd-server >= 4.1.0
Requires: xrootd-server < 5.0.0

with the already installed package having the versions:
[rpmbuild at el7build SPECS]$ rpm -qa --queryformat '%{name} %{version}\n' 
| grep xrootd | sort
xrootd 4.12.2
xrootd-client 4.12.2
xrootd-client-devel 4.12.2
xrootd-client-libs 4.12.2
xrootd-devel 4.12.2
xrootd-libs 4.12.2
xrootd-private-devel 4.12.2
xrootd-selinux 4.12.2
xrootd-server 4.12.2
xrootd-server-devel 4.12.2
xrootd-server-libs 4.12.2

when i'm trying to build i get:
error: Failed build dependencies:
          xrootd-devel < 5.0.0 is needed by 
          xrootd-server-devel < 5.0.0 is needed by 

Does anyone have any idea why the condition is not fulfilled?

i am aware of both
(under assuption that these holds true for the current 4.11.3 from centos 7)

Thanks a lot!