[CentOS] How to reset the USB subsystem?

Fri Jan 15 01:01:07 UTC 2021
H <agents at meddatainc.com>

On 01/14/2021 12:58 PM, Stephen John Smoogen wrote:
> On Thu, 14 Jan 2021 at 12:19, Fred <fred.fredex at gmail.com> wrote:
>> from a non-expert (me):
>> possibly figure out what happens when the device is plugged/unplugged and
>> doing that by hand. if you can find the udev file(s) that manage the
>> port(s) that get hung you may be able to figure out what those steps would
>> be.
>> or you could try, when hung, plugging it into a different USB port... some
>> motherboards have multiple USB controllers, so even if one gets wedged
>> tight, the other one(s) shouldn't be.
> So what can happen is that the USB device is seeing a lot of noise from the
> interface and shutdown the interface for a period of time. If you are
> extremely lucky, it will even send some sort of message to the computer bus
> it is doing this. In most other cases, the only fix is to reboot or
> temporarily unplug the devices connected to that particular USB controller
> (a computer may have multiple USB controllers since USB is a hubbed network
> and collisions and conflicts are expected for short periods.). [It used to
> be that you could cause a USB reset by removing the modules from the kernel
> and add them but that was a long time ago when a PS/2 keyboard was a real
> device and not an emulated PS/2 connected to the USB hub. ]
>> Good Luck!
>> Fred
>> On Thu, Jan 14, 2021 at 11:22 AM Frank Bures <listfrank1 at gmail.com> wrote:
>>> Hi,
>>> my USB connected printer goes into deep space from time to time probably
>>> due to a HW problem on the MoBo.
>>> Is there a way how to reset the USB subsystem the same way one can
>> restart
>>> networking or X without the necessity to reboot?
>>> Thanks
>>> Frank
>>> --
>>> <listfrank1 at gmail.com>
>>> _______________________________________________
>>> CentOS mailing list
>>> CentOS at centos.org
>>> https://lists.centos.org/mailman/listinfo/centos
>> _______________________________________________
>> CentOS mailing list
>> CentOS at centos.org
>> https://lists.centos.org/mailman/listinfo/centos
A few months ago I reported that I could not get a Logitech C922 ProStream video camera working on my Lenovo Thinkstation running CentOS 7. The BIOS was updated and the motherboard was replaced to no avail.

I could then confirm that the camera worked fine if I booted Ubuntu Live, hence no hardware issue with the computer, nor the camera which by the way worked fine on a laptop also running CentOS 7.

Since the USB subsystem did not recognize the camera when plugged in I reported this as a kernel/USB subsystem bug to RedHat. For some reason they made the bug private and I have not heard any more about it being worked on...

Howewer, two or so weeks ago I stumbled across https://zedt.eu/tech/linux/restarting-usb-subsystem-centos/ and used this procedure to reset the USB subsystem. This gets the camera working - most of the time...

The OP may want to try the same thing.