[CentOS] How to reset the USB subsystem?

Fri Jan 15 16:54:35 UTC 2021
Frank Bures <listfrank1 at gmail.com>

On 1/14/21 8:01 PM, H wrote:
22 ProStream video camera working on my Lenovo Thinkstation running CentOS 
7. The BIOS was updated and the motherboard was replaced to no avail.
> I could then confirm that the camera worked fine if I booted Ubuntu Live, hence no hardware issue with the computer, nor the camera which by the way worked fine on a laptop also running CentOS 7.
> Since the USB subsystem did not recognize the camera when plugged in I reported this as a kernel/USB subsystem bug to RedHat. For some reason they made the bug private and I have not heard any more about it being worked on...
> Howewer, two or so weeks ago I stumbled across https://zedt.eu/tech/linux/restarting-usb-subsystem-centos/ and used this procedure to reset the USB subsystem. This gets the camera working - most of the time...
> The OP may want to try the same thing.

Thanks a bunch.  I'll try this when the printer USB port goes dead again.



<listfrank1 at gmail.com>