[CentOS] Kickstart "Error setting up base repository"

Tue Jan 19 17:51:52 UTC 2021
James Pearson <james-p at moving-picture.com>

Alex Kirk wrote:
> I recently built my first CentOS kickstart config on a CentOS 7 system; it
> I've taken the anaconda-ks.cfg file created from a successful manual
> install (of both regular 8 and Stream), placed it on my DVD ISO, and
> wrapped things back up like I was doing with CentOS 7. I'm successfully
> beginning the installation, but running into "Error setting up base
> repository" - despite having not touched either the filesystem structure of
> the ISO, or the generated kickstart file that points at my repos.

I don't know if it's connected, but I had a problem (with a similar errors) when installing 8.3.2011 over httpd using a copy of the contents of the 8.3.2011 iso

My kickstart file contained:

 url --url="http://distro/CentOS/8.3.2011"
 repo --name="AppStream" --baseurl=http://disto/CentOS/8.3.2011/AppStream

This was a copy of what I has done with 8.1.1911 - which worked OK

I couldn't get 8.3.2011 to install, until I hacked things so the kickstart contained:

 url --url="http://distro/CentOS/8.3.2011/BaseOS"
 repo --name="AppStream" --baseurl=http://disto/CentOS/8.3.2011/AppStream

but I also had to put a symlink in the BaseOS subdir of:

 images -> ../images

i.e. it worked with 8.1.1911 but not 8.3.2011 (I never tried 8.2.2004)

I don't know if this is a bug or I'm doing something wrong?

James Pearson