[CentOS] Kickstart "Error setting up base repository"

Tue Jan 19 20:54:19 UTC 2021
Alex Kirk <akirk at corelight.com>

So adding on:

repo --name="BaseOS"

...didn't help at all. Neither did adding the symlink out of the BaseOS
directory to the images subdirectory above it.

I did notice this time, however, that when I click into the "Installation
Source" button of the UI where the erorr is, if I click on the repos being
read from my Kickstart file, there's a small error at the bottom of the
page that says "Repository name conflicts with internal repository name".
That seems weird, since again I'm basing this on a successful manual
install - why would that write a conflicting repo name to the config?

On Tue, Jan 19, 2021 at 12:52 PM James Pearson <james-p at moving-picture.com>

> Alex Kirk wrote:
> > I recently built my first CentOS kickstart config on a CentOS 7 system;
> it
> > I've taken the anaconda-ks.cfg file created from a successful manual
> > install (of both regular 8 and Stream), placed it on my DVD ISO, and
> > wrapped things back up like I was doing with CentOS 7. I'm successfully
> > beginning the installation, but running into "Error setting up base
> > repository" - despite having not touched either the filesystem structure
> of
> > the ISO, or the generated kickstart file that points at my repos.
> I don't know if it's connected, but I had a problem (with a similar
> errors) when installing 8.3.2011 over httpd using a copy of the contents of
> the 8.3.2011 iso
> My kickstart file contained:
>  url --url="http://distro/CentOS/8.3.2011"
>  repo --name="AppStream" --baseurl=http://disto/CentOS/8.3.2011/AppStream
> This was a copy of what I has done with 8.1.1911 - which worked OK
> I couldn't get 8.3.2011 to install, until I hacked things so the kickstart
> contained:
>  url --url="http://distro/CentOS/8.3.2011/BaseOS"
>  repo --name="AppStream" --baseurl=http://disto/CentOS/8.3.2011/AppStream
> but I also had to put a symlink in the BaseOS subdir of:
>  images -> ../images
> i.e. it worked with 8.1.1911 but not 8.3.2011 (I never tried 8.2.2004)
> I don't know if this is a bug or I'm doing something wrong?
> James Pearson
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> https://lists.centos.org/mailman/listinfo/centos

Alex Kirk
Global Principal, Suricata
akirk at corelight.com