[CentOS] Installing openLDAP on Centos 7

Thu Sep 30 14:49:15 UTC 2021
Gary Stainburn <gary.stainburn at ringways.co.uk>

I am following the howto on


which matches a number of other howto's.

I have tried this on two Centos 7 boxes and both fail in the same way 
when trying to set the certificates. I have tried <insert search engine 
here> without success.  I found that by adding '-d 1' you enable 
debugging, but the debugging did not help.

Anyone got any suggestions?  All steps prior to this worked successfully.


[root at eddie ldap]# ldapmodify -Y EXTERNAL -H ldapi:/// -f certs.ldif
SASL/EXTERNAL authentication started
SASL username: gidNumber=0+uidNumber=0,cn=peercred,cn=external,cn=auth
modifying entry "cn=config"
ldap_modify: Other (e.g., implementation specific) error (80)

[root at eddie ldap]# cat certs.ldif
dn: cn=config
changetype: modify
replace: olcTLSCertificateFile
olcTLSCertificateFile: /etc/openldap/certs/myldap.ringways.com.cert

dn: cn=config
changetype: modify
replace: olcTLSCertificateKeyFile
olcTLSCertificateKeyFile: /etc/openldap/certs/myldap.ringways.com.key
[root at eddie ldap]# ll /etc/openldap/certs/
total 72
-rw-r--r--. 1 ldap ldap 65536 Sep 30 11:19 cert8.db
-rw-r--r--. 1 ldap ldap 16384 Sep 30 11:19 key3.db
-rw-r--r--. 1 ldap ldap  1493 Sep 30 12:16 myldap.ringways.com.cert
-rw-r--r--. 1 ldap ldap  1704 Sep 30 12:16 myldap.ringways.com.key
-r--r-----. 1 ldap ldap    45 Jul 29  2020 password
-rw-r--r--. 1 ldap ldap 16384 Jul 29  2020 secmod.db
[root at eddie ldap]#