[CentOS] PHP version dilemma

Brian Mathis brian.mathis+centos at betteradmin.com
Fri Oct 5 12:58:42 EDT 2012


On Fri, Oct 5, 2012 at 12:57 PM, Todd Cary <todd at aristesoftware.com> wrote:
> I am running Centos 5.8; at least
>     uname -rmi
> gives me centos-release-5-8.el5.centos
>
> A CMS package is telling me that I need PHP 5.2x, however yum
> update says that I am fully up to date.
>
> Is there a "safe" way to upgrade PHP to 5.2x?
>
> Todd


Take a look at the IUS package repo:
   http://iuscommunity.org/pages/About.html

It's the one most people use to get PHP updates.  Stay away from the
official "php53" packages distributed with CentOS, as they don't
integrate well with many packages looking for php (it does not
"provide" the "php" capability)


❧ Brian Mathis


More information about the CentOS mailing list