[CentOS] floppy drives

Mon Apr 8 15:42:33 UTC 2013
Dale Dellutri <daledellutri at gmail.com>

On Sun, Apr 7, 2013 at 2:45 PM, mark <m.roth at 5-cent.us> wrote:

> Yes, really. I've got hundreds of the damn things here at home, and I
> want to go through them and get rid of them all.
> But... to do that I want to read them. I have both a 5.25" and a 3.5"
> drive, both are plugged in, but in the BIOS, all I see is the 3.5".
> Fine, I figure I'll take care of those.
> Nope. I see /dev/fd0 once I've booted up, but neither konqueror nor
> mount nor fdisk works - the latter telling me that /dev/fd0 is not a
> valid block device. After some googling, I tried modprobe floppy, which
> installed it, but still no joy.
> Anyone have a clue?

To debug this, I'd do the following:

1. Remove both USB plugs (I assume that these floppies are USB connected)
2. Reboot
3. Plug just one in, then do
and get the end of /var/log/messages
One of these might tell you where the floppy is connected in /dev.  It
might not
be /dev/fd0
4. If it doesn't show up immediately, try putting in a floppy disk and do 3
5. If it doesn't show up again, then it's probably dead.
6. If it does show, perhaps at /dev/sdb1, then create a file .mtoolsrc:
  # USB drive
  drive u: file="/dev/sdb1"
Then do
  mdir u:

Of course, it will probably show up at /dev/fd<n>.

Just my pre-tax 2 cents.

Dale Dellutri