[CentOS] CentOS 7, ATI video, ex-X

Fri Dec 16 16:08:52 UTC 2016
m.roth at 5-cent.us <m.roth at 5-cent.us>

A user running gnome came in this morning, clicked on the application
menu... and it was much shorter than he expected. He could get to firefox,
and googled about refreshing that... and found something that told him to

And that's it: I cannot get X up, at all. I just get the "oh, no,
something failed, please log out and try again".

Fully updated CentOS 7, [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 OEM],
and, like most of us, he uses two monitors.
I've tried removing the xorg.conf, and renaming
/etc/X11/xorg.conf.d/20-fglrx.conf, which was there (I didn't put it there
when I built the box a few months ago.)

I don't see anything even vaguely useful in the Xorg logs... and, for that
reason, not sure why I'm on Xorg.3.log, other than it may have been
created by startx. I've tried that, both as root, and as myself, get that
"oh, no" screen, and when I hit enter to log out, I get a live but black
screen, completely unresponsive.

I don't see any errors in dmesg or messages, and I've tried reinstalling
xorg-x11-drv-ati, which gives me

Does anyone have any ideas on this? I can't even get a single screen
working, though it's mirrored, of course, in text mode.