[CentOS] Installation on Knights Landing (KNL) machines failure

Tue Aug 22 17:56:51 UTC 2017
m.roth at 5-cent.us <m.roth at 5-cent.us>

Arif Ali wrote:
> Hi all,
> We have a customer, where we are trying to install CentOS 7.3 on the new
> Intel Knights Landing nodes, unfortunately, we are unable to install
> then using PXE boot.
> Now, I have a lot of experience of installation of machines using PXE
> boot, so the setup of that is not the problem. Both myself and my
> colleagues have looked through the problem, and we are unable to get
> much diagnosis of the problem.
YES. I was unable to build my four nodes using PXEboot, because the damn
thing won't take what it's given, and won't skip to the default target. It
INSISTS (ok, it is in the RFC, but...) on trying its MAC, or maybe it's
the UUID, I disremember, and spends *MINUTES - 4? 5? then tries again by
shortening it by one char, and again, and again, and by the time it tries
default, it's literally FIFTEEN MINUTES LATER, and the tftp/pxe has timed

Had to use a USB.... Strong suggestion: if you're doing more than one
node, I've posted more than once how to do an upgrade by rsync. I did one
of our four, tried, and tried, and finally gave up, and once the first was
correctly built, rsynced to the other three nodes.